NOTICE: Citizendium is still being set up on its newer server, treat as a beta for now; please see here for more.
Citizendium - a community developing a quality comprehensive compendium of knowledge, online and free. Click here to join and contribute—free
CZ thanks our previous donors. Donate here. Treasurer's Financial Report -- Thanks to our content contributors. --

Forum Talk:Technical Issues

From Citizendium, the Citizens' Compendium
Revision as of 17:22, 9 October 2017 by John Stephenson (Talk | contribs) (Some oddities: Server and front page issues)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Help system All recent posts Back to top Contact Administrator

Technical Issues
Choose from the following:

Discussion area for all technical issues, including non-content templates, server issues and extensions (bug reports/outages: Bugzilla or this group)

Pages: ContentGovernance and PolicyStyleManagementElections and ReferendaTechnical IssuesRequests for HelpCompetitors and Press
Archives
none (start Archive 1)

Managing Editor Decision regarding technical problems

The Managing Editor authorizes the Technical Staff to investigate and implement alternative less costly U.S. hosting, that would also include the restoration of e-mail inboxes and other services. -Anthony.Sebastian (talk) 00:13, 5 June 2016 (UTC)

Help test new server setup

Citizendium is now hosted by a newer less expensive server, and so the server expenses for 2014 December and later should now be $100/month rather than several times that.

Everything of value seems to have been copied from the older servers as an archive on the newer one so we shouldn't lose that when the old machines disappear within the next week.

The new server still needs substantial setup work done before before every service or feature that worked before works again.

In the meantime, the main wiki (which you are reading now) has been the priority to keep in continuous operation.

The main wiki is running under the latest MediaWiki, 1.24.0, and newer versions of some other dependencies.

The main wiki also makes use of a number of extensions plus customizations, and some of these have been updated too while others have yet to be updated for compatibility and so some sections of the wiki may be broken as a result; these are expected to be fixed over time but there is no schedule.

Currently @citizendium.org emails are not working, including constables; this is expected to be fixed sooner but also there is no schedule.

The readonly Simple Machines forums are not running right now but should come up later; meanwhile newer discussion was already changed several months ago to happen on the wiki or a Google group instead.

Citizendium should be treated like a beta for now; you can go ahead and try using the main wiki like normal, but some parts are known broken and other parts may also be broken; please go easy for now.

If you find any serious problems then please report them at http://en.citizendium.org/wiki/Forum_Talk:Technical_Issues so they can be triaged and fixed at the earliest.

You should assume that anything you do on the wiki will stick, so treat it as anything you are doing is for real.

Backups are still largely manual at the moment so keep in mind that recent changes might be lost if something bad happens and we have to restore; this is unlikely, but remember your work in case you might have to repeat it.

These are some known differences or issues at this time:

  • The wiki is slower than usual right now. Some work likely needs to be done with its configuration e.g. related to caching or something but traffic may also be a factor.
  • Creating new wiki users is broken or disabled right now; making the constables@ email work is a precondition to fixing this I think, another reason for that to be an outstanding priority; existing users can login though.
  • It sounds like creating new articles is currently broken.
  • A number of MediaWiki extensions probably need updating or fixing in order to resolve certain problems. MediaWiki itself was updated to the latest version and some extensions have been updated too, others are pending.
  • There is an outstanding mystery to resolve regarding the report under title Tracking below.
  • The Citizendium custom skin isn't installed yet so things look more like vanilla MediaWiki.
  • The orange heading bar doesn't appear on all pages as it usually does.

Issues reported by others on this page may still exist.

Darren Duncan (talk) 23:25, 15 December 2014 (UTC)


New server experience (comment, not issue)

My experience of using the new server is that so far, if anything it seems to be a faster and smoother experience than on the old servers. I'm not sure if use of the default Vector skin rather than CZ's own Pinkwich version has anything to do with this, or whether it's because we are now on MediaWiki 1.24, or some other reason. But all good so far. John Stephenson (talk) 11:53, 3 December 2014 (UTC)

No problem with an edit. The tools at the top of the editing area seem to have changed, but that may just be me. --Martin Wyatt (talk) 21:22, 4 December 2014 (UTC)

Problem (metadata)

At the moment it is not possible to test starting a new article on the new website. --Martin Wyatt (talk) 21:08, 5 December 2014 (UTC)

I started a new article by using the quick start process and then doing the metadata. However, the metadata form did not materialise. --Martin Wyatt (talk) 21:53, 8 December 2014 (UTC)
I'm having the same issue with a new test article Anny Kohli. Its Metadata form link is either incomplete or not working, instead I'm facing a wall of warning banners, which want me to create and code edit the No_metadata_template. A big no no IMHO. Pradyumna Singh (talk) 11:34, 9 December 2014 (UTC).
The Special:MetadataForm page definitely isn't working, but the templates on a metadata-less article work for me. I can hit 'show' and see a link to manually "Create the metadata template". John Stephenson (talk) 11:46, 9 December 2014 (UTC)
I created a metadata page without using the special metadata page, but then it did not appear. Now the article shows that it has a metadata page, but the link goes to a blank page. This blank page needs to be deleted so that it can eventually be replaced(Uganda Railway). --Martin Wyatt (talk) 19:34, 9 December 2014 (UTC)
It is displaying the correct categories on the main article, but the actual /Metadata subpage appears blank. It might come back under future adjustments. Unfortunately, at the moment I can't delete anything. John Stephenson (talk) 21:48, 9 December 2014 (UTC)

I'm back on CZ after a many-month hiatus and I just created a new article on Ellen Gates Starr with the quick start process and the metadata page. I'm pleased to report that very thing worked very smoothly. Roger A. Lohmann (talk) 22:06, 12 January 2016 (UTC)

Speed Issues

yesterday the site was painfully slow, 3-5 minutes to load a page while the servers shuttled between the old and -dev sites. Today its a little better, 1 minute to load a page. Hopefully its a DNS problem which it will sort itself out with propagation. Pradyumna Singh (talk) 08:08, 9 December 2014 (UTC)

- While DNS affected things last night, the main outstanding issue is the server is getting heavy traffic such as search spiders or something, and some config to help speed is pending.

@DD, check out WIKIPEDIA robots.txt for ideas.If spiders don't behave block them with .htaccess. It took 2 minutes for this edit section to load for me. I'm off to test create an article from scratch to see how it ports. Pradyumna Singh (talk) 10:46, 9 December 2014 (UTC)
The site's speed performance is steadily slowing down. Random speedtest sites show anywhere from 3 to 20 seconds for a page load. Perhaps log files need to be cleared out or specific IPs blocked. There is also an issue that the CSS and script files being loaded at run time are 3 times the size of their Wikipedia counterparts. Pradyumna Singh (talk) 17:14, 18 January 2015 (UTC)
Yes, painfully slow. Ro Thorpe (talk) 03:04, 21 January 2015 (UTC)

New to the project.. but so far the new setup seems extremely slow. I am a system administrator/DBA so if anyone could point me in the right direction I could assist.

Have we looked into using CloudFlare (http://cloudflare)? Even their free account is pretty decent. Is there a page with info about the new setup? Stack (I guess Lamp.. which OS, which web server Apache/Nginx)? specs on hardware (virtual VM, physical)? Francisco Reyes (talk) March 21, 2015

There's the Version page; otherwise someone more technically-minded can help. John Stephenson (talk) 19:48, 21 March 2015 (UTC)
Thanks John that is useful to know. Would still be nice to also include on that page the underlying infrastructure (or somewhere else). Info like PHP version, whether we use any PHP compilers, apache/Nginx.. I make a living, mostly, as Postgres DBA/Sysadmin.. so can certainly help on that part for sure. 9.4 is out and they already reached 9.4.1 so that may something to consider. I also did whois of the IP and seems we are using steadfast.net.. VPS/Physical? SSDs? Francisco Reyes (talk) 20:04, 21 March 2015 (UTC)

Tracking

Calls are being made to "adnxs.com" and "scorecardresearch.com" while loading pages. Is this emanating from MW or from the "addthis" widget ? page load waterfall Pradyumna Singh (talk) 11:11, 9 December 2014 (UTC)

'Random Page' link

The random page link is back on the default, i.e. any page. We previously had it set to exclude /subpages, stubs (status 3) and external articles (4). John Stephenson (talk) 11:51, 9 December 2014 (UTC)

Page deletion not possible

At the moment, I get an error if I try to delete any page: A database query error has occurred. This may indicate a bug in the software. John Stephenson (talk) 21:48, 9 December 2014 (UTC)

Thanks! John Stephenson (talk) 00:16, 11 December 2014 (UTC)

Category

Categories are not accessible if you click on them. I get a blank page Pradyumna Singh (talk) 09:44, 10 December 2014 (UTC)

  • Seems to be a problem with the CategoryTree extension. I have disabled it for now, so categories should be viewable again. Greg Sabino Mullane (talk) 23:20, 16 December 2014 (UTC)
  • A newer version of CagtegoryTree is now installed and enabled. Please report back if it breaks normal Category navigation again. Greg Sabino Mullane (talk) 03:05, 17 August 2015 (UTC)

DEV site

The dev site is now a redirect to CZ. But it was indexed by the engines, and I suppose there is a feeding frenzy by their agents to index the dev site, by re-indexing CZ. As CZ is back to its canonical state [is it ??], I suggest that an Error 301 is placed on the dev site immediately and or it is DISASSOCIATED from CZ. Not doing so may incur stiff SEO penalties by CZ.

Also, bad spiders and bots MUST be SWIFTLY blocked by robots.txt and other means eg. How to keep bad robots, spiders and web crawlers away.

Another thing, poorly configured MW installations generate multiple server request loops, which often seem like DDOS attacks. Server log analysis would be useful.Pradyumna Singh (talk) 10:00, 10 December 2014 (UTC)

Pradyumna Singh, it seems like we should have a more direct talk in private, as you seem savvy. Please send me a direct email right away, where we can continue discussion. If you don't know my address, do a Google search on my name and it should be obvious in the first page of results; I won't be posting my address on the wiki. Darren Duncan (talk) 11:03, 10 December 2014 (UTC) Also, there has been a robots.txt since Sunday night or so, it was copied from the old server; see http://en.citizendium.org/robots.txt .

As of Monday night, en.citizendium.org is the canonical domain, same as it was on the old server, and currently requests to any other domain will 302 redirect to it. I assumed a 302 would not cause any short term SEO changes, while a 301 would.

Since en.citizendium.org has always been up, aside from an hour or a minute here or there, and there was never any auto-redirect of requests from en.citizendium.org to any other domain, I would expect its SEO rankings to be unaffected. As to citizendium-dev.org, that was always a separate copy and even if it was indexed there shouldn't be any SEO effects, unless duplication does that. I could change citizendium-dev.org to return forbidden errors or do you mean something else about disassociation? I had made it redirect for now because some external announcements linked to the domain.

Also, citizendium.org used to redirect to en.citizendium.org but I don't recall the exact mechanism or if a clone of the site had lived there for some reason, so for now I made that 302 as well to buy time.

Currently all other domains like the simple machines forum domain also 302 to en.citizendium.org until those are restored. Or alternately those could be made to return forbidden errors instead.

What do you suggest for action that would do best from an SEO perspective? And email me. Note, my timezone is UTC-8/PT.

Wikipedia checkbox and link

The box on the edit page that is ticked to indicate Wikipedia source material and the "Some content on this page..." note are missing. John Stephenson (talk) 00:16, 11 December 2014 (UTC)

Redirects from "www.citizendium.org"

@DD, the redirect from "www" is adding an extra '/' and generating 404s from "en." eg. "www.citizendium.org/oneyearandthriving.html" --> "http://en.citizendium.org//oneyearandthriving.html". This content is published on "www." and not on "en.cz" Pradyumna Singh (talk) 10:11, 12 December 2014 (UTC)

Mailbox inaccessible

The mail.citizendium.org server is not responding (checked by Matt and I), so we can't read anything sent to constables@. Mail isn't bouncing, though, so presumably it's still being saved. John Stephenson (talk) 11:28, 14 December 2014 (UTC)

The new server is not setup for receiving email yet as far as I know, so I would expect that email sent to anything @ citizendium.org would be failing right now. As far as I know constables@ is the main one that needs to work but I don't know yet about others. John, see your email where I have further questions for you etc about email setup. Darren Duncan (talk) 23:36, 14 December 2014 (UTC)
It's bouncing now. John Stephenson (talk) 12:47, 15 December 2014 (UTC)
Is the mailbox working now ? Pradyumna Singh (talk) 06:40, 3 January 2015 (UTC)
None of the citizendium.org addresses are currently working. John Stephenson (talk) 00:34, 11 March 2015 (UTC)

Preferences

These, or some of them, seem to have changed. Presumably reset to default. I noticed the system adding any page I edited to my watchlist, and had to go to my preferences to change. Peter Jackson (talk) 11:59, 18 December 2014 (UTC)

Categories

These seem to be listing things in an odd way. When the metadata for an article specify it should be alphabetized other than under its first word, the category pages do that but add a new heading:

S

Saxophone

J

John Smith

sort of thing (I haven't tried to analyse the exact pattern). Peter Jackson (talk) 11:13, 29 December 2014 (UTC)

OK. In Category:Religion Authors I see headings A M O D S F J L I R Z Y E P N G B H K C U W A D M F J W C L K V R G H B P N E Y I T S H T F A C S N O D M J L Y B R E P K W V Z. Peter Jackson (talk) 14:17, 17 August 2015 (UTC)
Wow, that was a mess. I ran the updateCollation script and it seems to have at least fixed that page. Not sure yet about newly categorized pages. Greg Sabino Mullane (talk) 21:38, 18 August 2015 (UTC)
I'm still seeing the same mess. Might it depend which browser (and/or server?)? Or could both the computer systems I've tried be using cached versions of that page but not this one? Peter Jackson (talk) 17:00, 20 August 2015 (UTC)
Yes, must be cached for you, I just reloaded the page and it is all A-Z for me. Try the shift-reload trick (hold the shift button while clicking reload - works on most browsers). Greg Sabino Mullane (talk) 18:52, 20 August 2015 (UTC)

Subpages template issue

I find that if I try to create a /Definition subpage for an article by clicking on the red link in the banner supplied via the {{subpages}} template, instructions but not the template itself appear in the edit window. When you click the link you're supposed to get <noinclude>{{subpages}}</noinclude> at the top of the edit window, but instead there is a blank line. The instructions appear as normal below. However, if I go to to the def preload template, the subpages line appears. This does not occur with any other red links on the banner. Test by going to e.g. Talk:1876th Communications Squadron and clicking the red links. John Stephenson (talk) 14:38, 2 January 2015 (UTC)

Another issue with the same template: it registers an error for any page deeper than one subpage, e.g. anything under ARTICLENAME/Catalogs/SUBPAGENAME is wrongly registered as an article without metadata. There are now hundreds of subpages registered at Category:False Start Move as a result. John Stephenson (talk) 17:28, 17 July 2015 (UTC)

As this may be difficult to fix, I have created the ReturnToSubpages template as an alternative to {{subpages}}. An example is at A Christmas Carol/Catalogs/Actors who have played Ebenezer Scrooge.
Don't try to add metadata for sub-subpages, as the subpages template wrongly demands - you will only create useless pages and more error messages elsewhere. Metadata pages are for main articles only. John Stephenson (talk) 21:33, 1 August 2015 (UTC)

HTML markup pre-processor issue

HTML markup doesn't seem to be recognised consistently eg:

Pradyumna Singh (talk) 03:27, 3 January 2015 (UTC)

Equations using <math> are not type set

I happened to check an old article I wrote for CZ: Diabatic transformation. All tags <math> are non-functioning. I checked Maxwell equations: same thing. I suggest that the constable on duty either removes the articles that contain <math> or fix its function. As it is now it is a mess that reflects poorly on CZ. --Paul Wormer (talk) 08:36, 8 January 2015 (UTC)

No need for such drastic steps. All it requires is a MediaWiki extension to be reinstalled. Probably Extension:Math or some similar TeX er. Pradyumna Singh (talk) 09:02, 8 January 2015 (UTC)
If somebody can access the old 1.16 folders and checkout "LocalSettings.php" and the contents of the /extension folder, possibly some more of these will tumble out like Ex:Category Tree. BTW, this extension is essential nowadays. The <meta "copyright"> tag is also outputting GFL-1.3+ for articles instead of CC-BY-SA-3.0. Pradyumna Singh (talk) 09:11, 8 January 2015 (UTC)
Equations in the few articles I checked using an iPad are not translated. For example Feedback, Step response, and Centrifugal force. John R. Brews (talk) 17:49, 16 May 2015 (UTC)
No progress as yet in getting math typeset. John R. Brews (talk) 15:24, 1 June 2015 (UTC)
This problem persists. For example,
is not typeset. Greg Sabino was contacted about this issue twice, but apparently cannot resolve it. John R. Brews (talk) 16:25, 10 July 2015 (UTC)
A motion has been passed to look into this matter. See http://en.citizendium.org/wiki?title=CZ_Talk:Council_Discussions&diff=prev&oldid=100847705 John R. Brews (talk) 01:45, 23 July 2015 (UTC)
No action yet taken. John R. Brews (talk) 01:01, 2 August 2015 (UTC)

Typo in site notice

Could someone who has access please correct setup (noun) to set up (verb) in the site notice at the top of every page? Thanks. Ro Thorpe (talk) 01:25, 10 January 2015 (UTC)

Still waiting for this. It looks very bad. Ro Thorpe (talk) 03:03, 21 January 2015 (UTC)

Many thanks to John for fixing it. Ro Thorpe (talk) 01:17, 23 January 2015 (UTC)

Bug in Special:Watchlist

Articles for Approval This special page is supposed to include a link at the top directing users to articles which are in the process of being approved but instead it shows the code: Nominated for Approval: <categorytree mode="all" hideprefix=always hideroot=on>ApprovalCall</categorytree> . Justin Anthony Knapp (talk) 06:14, 13 January 2015 (UTC)

I had reported this 10 days ago. It needs a MediaWiki extension to be reinstalled. Pradyumna Singh (talk) 13:44, 13 January 2015 (UTC)

Robots.txt

This file, which tells search engines what not to index, doesn't seem to be working - I've found many User: and User_talk: pages listed and cached in Google search results. We have a policy that these not be indexed. John Stephenson (talk) 18:48, 27 February 2015 (UTC)

Per Google, "robots.txt" is not a 100% solution. If Google finds external links point to any page, it will index them ignoring robots.txt. The user pages showing up in G-search are explicitly banned by "Disallow: /wiki/User:" in the robots.txt !! The solution here is to set up a Google Webmaster Tools a/c to debug it / remove *URLs from the index Pradyumna Singh (talk) 19:14, 27 February 2015 (UTC)
Shouldn't there be User-agent: * above the long list of disallows..? At any rate, this is also a priority since if Google etc. are spidering everything, that could be why the wiki is currently slow. John Stephenson (talk) 00:29, 11 March 2015 (UTC)
Darren has adjusted the robots.txt file. If we've got it right, Google will start to strip disallowed pages out of its index. How long this will take we don't know. John Stephenson (talk) 12:17, 12 March 2015 (UTC)

Emerging technology trends for the 'pedias

Must read this - Wikimedia Metrics Dec. 2014 makes 2 trends clear - a) MOBILE, MOBILE & MOBILE b) Massive reader shift to the Global South - especially India - driven by mobile. Other trends are importance of 'structured data', and WMF sliding in Latin America, and Google downgrading Wikipedia by 38%. Pradyumna Singh (talk) 19:38, 27 February 2015 (UTC)

Not sure how serious this is...

I wrote a python program to help me figure out how many unique articles I started here. Its input was the output of successive pages from my contribution history.

I found that the Capital "N" that marks a brand new article wasn't marking any of the oldest articles I started, from September 2008...

Yes, this would be a trivial bug, if I haven't made a mistake in my reporting, so I report it only in case it is a manifestation of a larger hiccup.

Details follow:

  • I always use "first draft" as the edit summaries of my first drafts.
  • My python program used two regular expressions to find just the programs, and no talk pages or other subpages. """ N (?P<fname>[^/]+) +.first draft."""

Cheers! George Swan (talk) 20:35, 1 March 2015 (UTC)

Footnote templates?

See Talk:English spellings#Morgellons. Peter Jackson (talk) 17:21, 2 April 2015 (UTC)

pdf links

Anyone know the right way to do these? I've just tried putting one in 2015 United Kingdom general election#Results by putting http:// before the address shown at top left, but it doesn't work. Peter Jackson (talk) 14:52, 1 June 2015 (UTC)

Peter: Here is an example that works. It consists of [ "http:// address" "blank space" "title" ] What is it like to be a bat? John R. Brews (talk) 15:23, 1 June 2015 (UTC)

Not directly helpful. I notice it gives five layers of address before the actual title to be found at top left, so no doubt something of the sort needs to be added to the one I was trying to put in. But how does one find out what that should be? Peter Jackson (talk) 08:53, 2 June 2015 (UTC)
Now found a way: hover over an existing link to the pdf and copy out using pen(cil) and paper the (extremely long) URL visible at the bottom of the screen. There really ought to be an easier way. Peter Jackson (talk) 10:56, 9 July 2015 (UTC)

Sidebar and templates not loading

The MediaWiki sidebar on the left of every page sometimes doesn't load, instead defaulting to the basic links. This happens whether logged in or out and regardless of what browser I use. When it occurs, only 'Main page' to 'Help' and the Tools menu are visible. I've also encountered a problem where a template gets edited but it doesn't update on the pages where it's used - caching issue? Thanks. John Stephenson (talk) 16:58, 17 June 2015 (UTC)

I sometimes get a perhaps related phenomenon recently: en.citizendium.org/wiki/Welcome_to_Citizendium has the full sidebar, but en.citizendium.org displays a version of the same page with only truncated sidebar. Peter Jackson (talk) 10:38, 18 June 2015 (UTC)

Subpage problem

In Victorian Literature, I created a new subpage, Catalogs, which was not there before. This has now appeared twice in the subpage bar. I have not looked to see whether they both have the same content, because with everything running so slow (again) it would take me too long. For the same reason I am not going to check this before saving it. --Martin Wyatt (talk) 15:36, 2 September 2015 (UTC)

/Timelines and /Catalogs links appear automatically when the pages are created; adding them under 'sub1' etc. in the Metadata page just produces duplicate links in the article's navigation bar. The 'sub' entries are for identifying subpages with unique or unrecognised titles, e.g. you decide you want a subpage called /Parody - that won't show up unless you add it to the Metadata page. The problem is knowing which subpage titles will just pop up, and which have to be defined in the metadata. There's a list of recognised titles under 'Unused subpages' at the top of the Talk page. Not at all obvious, but there you go. And yes, the server is very slow today. John Stephenson (talk) 15:53, 3 September 2015 (UTC)

Language variants

I don't know whether this is anything to do with CZ, or whether it's the computer system I'm working on. Whichever it is redlines British spellings and sometimes autocorrects them to American. If it's going to do that sort of thing at all, it should be to the variant set for the article in question. Peter Jackson (talk) 08:56, 26 July 2016 (UTC)

That's not caused by the MediaWiki software - it's far too primitive for that. :) John Stephenson (talk) 16:18, 27 July 2016 (UTC)

Embedded videos no longer working

It used to be possible to embed videos from YouTube and other sites in wiki pages; however, this no longer works. See e.g. here. Can someone take a look? It seems to be a missing extension. Thanks. John Stephenson (talk) 17:10, 4 December 2016 (UTC)

Wiki backups

Thanks to Francisco Reyes for getting our backup system on-line. (See here for details.) To download copies of recent pages, use either of these links (70-90MB):

Go-slow

The site finally seems to be working properly again, after weeks of going extremely slowly, or not at all. No announcement about the problem was ever made either here or by the mailing list. The only mention I've seen was on RationalWiki. Before that, my only reason for concluding it wasn't just me was the low edit rate. Peter Jackson (talk) 09:54, 24 June 2017 (UTC)

Some oddities

1. Newly started articles are not getting listed under the appropriate Workgroup. I assume this should happen automatically when the Metadata page is completed.

2. If you click on any of the main subject areas shown on the home page, you don't get redirected to the article on that subject, or to the Workgroup, but to the /Related Articles page for the subject.

3. The Random Page function is still not working as it should.

--Martin Wyatt (talk) 21:26, 8 October 2017 (UTC)

Martin, I don't see problems with Special:Random--I chose it twice and got two different pages. Justin Anthony Knapp (talk) 04:01, 9 October 2017 (UTC)
I think it is only supposed to land on main pages, not sub-pages, and likewise it should not land on articles which are either stubs or without metadata. Mind you, it does show the number of small out-of-date articles floating round the system. --Martin Wyatt (talk) 13:26, 9 October 2017 (UTC)
You're right, and it was one of the things lost when the wiki was upgraded. It needs some change on the server settings that only the Tech Staff can carry out. For (1): I can see them in the lists. Maybe this is a caching issue and needs a while to come through. (The server is not the fastest.) (2): that's to the benefit of readers, rather than Authors. In my view, going to the article would be too specific, and going to the workgroup would be confusing, when Related Articles pages also list them and in a more user-friendly way (if someone's written them, that is.) John Stephenson (talk) 17:22, 9 October 2017 (UTC)