NOTICE: Citizendium is still being set up on its newer server, treat as a beta for now; please see here for more.
Citizendium - a community developing a quality comprehensive compendium of knowledge, online and free. Click here to join and contribute—free
CZ thanks our previous donors. Donate here. Treasurer's Financial Report -- Thanks to our content contributors. --

Difference between revisions of "Forum Talk:Technical Issues"

From Citizendium, the Citizens' Compendium
Jump to: navigation, search
(Not sure how serious this is...: new section)
(Not sure how serious this is...)
Line 218: Line 218:
 
Details follow:
 
Details follow:
 
* I always use "first draft" as the edit summaries of my first drafts.   
 
* I always use "first draft" as the edit summaries of my first drafts.   
* My python program used two regular expressions to find just the programs, and no talk pages or other subpages.  """ N (?P<fname>[^/]+ .first draft.)"""
+
* My python program used two regular expressions to find just the programs, and no talk pages or other subpages.  """ N (?P<fname>[^/]+) +.first draft."""
  
 
Cheers!  [[User:George Swan|George Swan]] ([[User talk:George Swan|talk]]) 20:35, 1 March 2015 (UTC)
 
Cheers!  [[User:George Swan|George Swan]] ([[User talk:George Swan|talk]]) 20:35, 1 March 2015 (UTC)

Revision as of 20:41, 1 March 2015

Help system All recent posts Back to top Contact Administrator

Technical Issues
Choose from the following:

Discussion area for all technical issues, including non-content templates, server issues and extensions (bug reports/outages: Bugzilla or this group)

Pages: ContentGovernance and PolicyStyleManagementElections and ReferendaTechnical IssuesRequests for HelpCompetitors and Press
Approvals Committee AnnouncementsDiscussionsComments
Archives
none (start Archive 1)

Help test new server setup

Citizendium is now hosted by a newer less expensive server, and so the server expenses for 2014 December and later should now be $100/month rather than several times that.

Everything of value seems to have been copied from the older servers as an archive on the newer one so we shouldn't lose that when the old machines disappear within the next week.

The new server still needs substantial setup work done before before every service or feature that worked before works again.

In the meantime, the main wiki (which you are reading now) has been the priority to keep in continuous operation.

The main wiki is running under the latest MediaWiki, 1.24.0, and newer versions of some other dependencies.

The main wiki also makes use of a number of extensions plus customizations, and some of these have been updated too while others have yet to be updated for compatibility and so some sections of the wiki may be broken as a result; these are expected to be fixed over time but there is no schedule.

Currently @citizendium.org emails are not working, including constables; this is expected to be fixed sooner but also there is no schedule.

The readonly Simple Machines forums are not running right now but should come up later; meanwhile newer discussion was already changed several months ago to happen on the wiki or a Google group instead.

Citizendium should be treated like a beta for now; you can go ahead and try using the main wiki like normal, but some parts are known broken and other parts may also be broken; please go easy for now.

If you find any serious problems then please report them at http://en.citizendium.org/wiki/Forum_Talk:Technical_Issues so they can be triaged and fixed at the earliest.

You should assume that anything you do on the wiki will stick, so treat it as anything you are doing is for real.

Backups are still largely manual at the moment so keep in mind that recent changes might be lost if something bad happens and we have to restore; this is unlikely, but remember your work in case you might have to repeat it.

These are some known differences or issues at this time:

  • The wiki is slower than usual right now. Some work likely needs to be done with its configuration e.g. related to caching or something but traffic may also be a factor.
  • Creating new wiki users is broken or disabled right now; making the constables@ email work is a precondition to fixing this I think, another reason for that to be an outstanding priority; existing users can login though.
  • It sounds like creating new articles is currently broken.
  • A number of MediaWiki extensions probably need updating or fixing in order to resolve certain problems. MediaWiki itself was updated to the latest version and some extensions have been updated too, others are pending.
  • There is an outstanding mystery to resolve regarding the report under title Tracking below.
  • The Citizendium custom skin isn't installed yet so things look more like vanilla MediaWiki.
  • The orange heading bar doesn't appear on all pages as it usually does.

Issues reported by others on this page may still exist.

Darren Duncan (talk) 23:25, 15 December 2014 (UTC)


New server experience (comment, not issue)

My experience of using the new server is that so far, if anything it seems to be a faster and smoother experience than on the old servers. I'm not sure if use of the default Vector skin rather than CZ's own Pinkwich version has anything to do with this, or whether it's because we are now on MediaWiki 1.24, or some other reason. But all good so far. John Stephenson (talk) 11:53, 3 December 2014 (UTC)

No problem with an edit. The tools at the top of the editing area seem to have changed, but that may just be me. --Martin Wyatt (talk) 21:22, 4 December 2014 (UTC)

Problem (metadata)

At the moment it is not possible to test starting a new article on the new website. --Martin Wyatt (talk) 21:08, 5 December 2014 (UTC)

I started a new article by using the quick start process and then doing the metadata. However, the metadata form did not materialise. --Martin Wyatt (talk) 21:53, 8 December 2014 (UTC)
I'm having the same issue with a new test article Anny Kohli. Its Metadata form link is either incomplete or not working, instead I'm facing a wall of warning banners, which want me to create and code edit the No_metadata_template. A big no no IMHO. Pradyumna Singh (talk) 11:34, 9 December 2014 (UTC).
The Special:MetadataForm page definitely isn't working, but the templates on a metadata-less article work for me. I can hit 'show' and see a link to manually "Create the metadata template". John Stephenson (talk) 11:46, 9 December 2014 (UTC)
I created a metadata page without using the special metadata page, but then it did not appear. Now the article shows that it has a metadata page, but the link goes to a blank page. This blank page needs to be deleted so that it can eventually be replaced(Uganda Railway). --Martin Wyatt (talk) 19:34, 9 December 2014 (UTC)
It is displaying the correct categories on the main article, but the actual /Metadata subpage appears blank. It might come back under future adjustments. Unfortunately, at the moment I can't delete anything. John Stephenson (talk) 21:48, 9 December 2014 (UTC)

Speed Issues

yesterday the site was painfully slow, 3-5 minutes to load a page while the servers shuttled between the old and -dev sites. Today its a little better, 1 minute to load a page. Hopefully its a DNS problem which it will sort itself out with propagation. Pradyumna Singh (talk) 08:08, 9 December 2014 (UTC)

- While DNS affected things last night, the main outstanding issue is the server is getting heavy traffic such as search spiders or something, and some config to help speed is pending.

@DD, check out WIKIPEDIA robots.txt for ideas.If spiders don't behave block them with .htaccess. It took 2 minutes for this edit section to load for me. I'm off to test create an article from scratch to see how it ports. Pradyumna Singh (talk) 10:46, 9 December 2014 (UTC)
The site's speed performance is steadily slowing down. Random speedtest sites show anywhere from 3 to 20 seconds for a page load. Perhaps log files need to be cleared out or specific IPs blocked. There is also an issue that the CSS and script files being loaded at run time are 3 times the size of their Wikipedia counterparts. Pradyumna Singh (talk) 17:14, 18 January 2015 (UTC)
Yes, painfully slow. Ro Thorpe (talk) 03:04, 21 January 2015 (UTC)

Tracking

Calls are being made to "adnxs.com" and "scorecardresearch.com" while loading pages. Is this emanating from MW or from the "addthis" widget ? page load waterfall Pradyumna Singh (talk) 11:11, 9 December 2014 (UTC)

'Random Page' link

The random page link is back on the default, i.e. any page. We previously had it set to exclude /subpages, stubs (status 3) and external articles (4). John Stephenson (talk) 11:51, 9 December 2014 (UTC)

Page deletion not possible

At the moment, I get an error if I try to delete any page: A database query error has occurred. This may indicate a bug in the software. John Stephenson (talk) 21:48, 9 December 2014 (UTC)

Thanks! John Stephenson (talk) 00:16, 11 December 2014 (UTC)

Category

Categories are not accessible if you click on them. I get a blank page Pradyumna Singh (talk) 09:44, 10 December 2014 (UTC)

  • Seems to be a problem with the CategoryTree extension. I have disabled it for now, so categories should be viewable again. Greg Sabino Mullane (talk) 23:20, 16 December 2014 (UTC)

DEV site

The dev site is now a redirect to CZ. But it was indexed by the engines, and I suppose there is a feeding frenzy by their agents to index the dev site, by re-indexing CZ. As CZ is back to its canonical state [is it ??], I suggest that an Error 301 is placed on the dev site immediately and or it is DISASSOCIATED from CZ. Not doing so may incur stiff SEO penalties by CZ.

Also, bad spiders and bots MUST be SWIFTLY blocked by robots.txt and other means eg. How to keep bad robots, spiders and web crawlers away.

Another thing, poorly configured MW installations generate multiple server request loops, which often seem like DDOS attacks. Server log analysis would be useful.Pradyumna Singh (talk) 10:00, 10 December 2014 (UTC)

Pradyumna Singh, it seems like we should have a more direct talk in private, as you seem savvy. Please send me a direct email right away, where we can continue discussion. If you don't know my address, do a Google search on my name and it should be obvious in the first page of results; I won't be posting my address on the wiki. Darren Duncan (talk) 11:03, 10 December 2014 (UTC) Also, there has been a robots.txt since Sunday night or so, it was copied from the old server; see http://en.citizendium.org/robots.txt .

As of Monday night, en.citizendium.org is the canonical domain, same as it was on the old server, and currently requests to any other domain will 302 redirect to it. I assumed a 302 would not cause any short term SEO changes, while a 301 would.

Since en.citizendium.org has always been up, aside from an hour or a minute here or there, and there was never any auto-redirect of requests from en.citizendium.org to any other domain, I would expect its SEO rankings to be unaffected. As to citizendium-dev.org, that was always a separate copy and even if it was indexed there shouldn't be any SEO effects, unless duplication does that. I could change citizendium-dev.org to return forbidden errors or do you mean something else about disassociation? I had made it redirect for now because some external announcements linked to the domain.

Also, citizendium.org used to redirect to en.citizendium.org but I don't recall the exact mechanism or if a clone of the site had lived there for some reason, so for now I made that 302 as well to buy time.

Currently all other domains like the simple machines forum domain also 302 to en.citizendium.org until those are restored. Or alternately those could be made to return forbidden errors instead.

What do you suggest for action that would do best from an SEO perspective? And email me. Note, my timezone is UTC-8/PT.

Wikipedia checkbox and link

The box on the edit page that is ticked to indicate Wikipedia source material and the "Some content on this page..." note are missing. John Stephenson (talk) 00:16, 11 December 2014 (UTC)

Redirects from "www,citizendium.org"

@DD, the redirect from "www" is adding an extra '/' and generating 404s from "en." eg. "www.citizendium.org/oneyearandthriving.html" --> "http://en.citizendium.org//oneyearandthriving.html". This content is published on "www." and not on "en.cz" Pradyumna Singh (talk) 10:11, 12 December 2014 (UTC)

Mailbox inaccessible

The mail.citizendium.org server is not responding (checked by Matt and I), so we can't read anything sent to constables@. Mail isn't bouncing, though, so presumably it's still being saved. John Stephenson (talk) 11:28, 14 December 2014 (UTC)

The new server is not setup for receiving email yet as far as I know, so I would expect that email sent to anything @ citizendium.org would be failing right now. As far as I know constables@ is the main one that needs to work but I don't know yet about others. John, see your email where I have further questions for you etc about email setup. Darren Duncan (talk) 23:36, 14 December 2014 (UTC)
It's bouncing now. John Stephenson (talk) 12:47, 15 December 2014 (UTC)
Is the mailbox working now ? Pradyumna Singh (talk) 06:40, 3 January 2015 (UTC)

Preferences

These, or some of them, seem to have changed. Presumably reset to default. I noticed the system adding any page I edited to my watchlist, and had to go to my preferences to change. Peter Jackson (talk) 11:59, 18 December 2014 (UTC)

Categories

These seem to be listing things in an odd way. When the metadata for an article specify it should be alphabetized other than under its first word, the category pages do that but add a new heading:

S

Saxophone

J

John Smith

sort of thing (I haven't tried to analyse the exact pattern). Peter Jackson (talk) 11:13, 29 December 2014 (UTC)

Subpages template issue

I find that if I try to create a /Definition subpage for an article by clicking on the red link in the banner supplied via the {{subpages}} template, instructions but not the template itself appear in the edit window. When you click the link you're supposed to get <noinclude>{{subpages}}</noinclude> at the top of the edit window, but instead there is a blank line. The instructions appear as normal below. However, if I go to to the def preload template, the subpages line appears. This does not occur with any other red links on the banner. Test by going to e.g. Talk:1876th Communications Squadron and clicking the red links. John Stephenson (talk) 14:38, 2 January 2015 (UTC)

HTML markup pre-processor issue

HTML markup doesn't seem to be recognised consistently eg:

Pradyumna Singh (talk) 03:27, 3 January 2015 (UTC)

== Failed to parse (syntax error):